January 2010

KDE SC 4.3.4 moved from PPA to karmic-backports

KDE SC 4.3.4 is now in karmic-backports and will be removed from the PPA shortly. Even if you have the PPA packages, please upgrade to the versions in karmic-backports. There are security fixes included in karmic-backports that were not in the PPA packages. The Backports repository is not enabled by default, so you may need to enable it in KPackageKit. Instructions for this are found here. To manually enable it, edit your /etc/apt/sources/list and uncomment the line

KDE SC 4.4 Release Candidate 1 packages available

Packages for the first release candidate of the KDE Software Compilation 4.4 are available.

Users of the Lucid development release are advised not to upgrade yet, as the packages are only half-built due to a breakage of the underlying graphics stack. The Ubuntu Xorg team is working fervently to resolve the issue as soon as possible.

Users of our stable 9.10 release can install it from the Kubuntu Beta PPA.

Amarok 2.2.2 Rocks the Desktop

Amarok 2.2.2 has been released to make your desktop rock.

Users of the Lucid development release are advised not to upgrade yet, as the packages are only half-built due to a breakage of the underlying graphics stack. The Ubuntu Xorg team is working fervently to resolve the issue as soon as possible.

Users of our stable 9.10 release can install it from the Kubuntu Backports PPA.

Lucid Alpha 2 Released

The second alpha release of Kubuntu Lucid has been released. KDE, Amarok and much more have received upgrades in this version. See our release page for where to get it, new features and notable problems.

KDE SC 4.4 Release Candidate 2 packages available

Packages for the second release candidate of the KDE Software Compilation 4.4 are available.

Users of the Lucid development release can upgrade to the newest packages.

Users of our stable 9.10 release can install it from the Kubuntu Beta PPA.

KDE Software Compilation 4.3.5 in Backports

KDE SC 4.3.5 is now in karmic-backports. The Backports repository is not enabled by default, so you may need to enable it in KPackageKit. Instructions for this are found on the help wiki. To manually enable it, edit your /etc/apt/sources.list and uncomment the line deb http://archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse. When upgrading from 4.3.2 to 4.3.4, some package recommendations have changed, so using dist-upgrade (or full-upgrade in aptitude) may be needed.